ZOOM REQUIREMENTS

Please update your Zoom to version 5.3.2 BEFORE the conference.

HOW TO UPDATE

If you have any issues in regards to Zoom, please contact your chairs and hkvsamun@gmail.com.